Issues Advancing time in Step 3 CCS

2/7/2022 11:26:12 AM
Has anyone else had this issue or found a solution where the program seems to glitch when you're trying to advance time to next result, or even if you're inputting the manually to advance time a certain amount - it gets "stuck" on the first set of results and keeps popping up over and over again and doesn't let you do anything else? I've tried switching computers as well as browsers and emptying my cache and turning off apps, but it keeps on doing it. I can't beyond the first set of labs I get even when I've already addressed them.

Would appreciate anyone's help with this. (I already contacted UWorld support and they only said to empty the cache, which I've done, and it doesn't work.)

6/8/2022 10:21:58 AM
Hello. I am having the same issue with my results report getting stuck and pops up repeatedly on ccs cases step 3.
Can anyone help me with a solution for this?
thank you in advance.

3/9/2023 10:20:55 AM
Same problem, where is UWORLD?

4/6/2024 2:33:55 PM
Also having this issue with every case I have tried.

pages: 1

We use cookies to learn how you use our website and to ensure that you have the best possible experience.
By continuing to use our website, you are accepting the use of cookies. Learn more